大智慧经典版的指标装入
打开–功能–自编指标–点常用-新建

稳赚线

Var1:=(2*CLOSE+HIGH+LOW)/4;
Var2:=LLV(LOW,34);
Var3:=HHV(HIGH,34);
xx:EMA((Var1-Var2)/(Var3-Var2)*100,13);
yy:EMA(0.667*REF(xx,1)+0.333*xx,2) , ;
STICKLINE(CROSS(xx,20) AND yy<xx,xx+19,xx-10,4,0),COLORRED;
DRAWTEXT(CROSS(xx,20) AND yy<xx,xx-5,’百分之三! ‘);
STICKLINE(yy<xx,xx,yy,4,0),COLORRED;
选股:IF(CROSS(xx,yy) AND xx<20 ,30,0);
逃顶:IF(FILTER(CROSS(YY,XX) AND xx>80 ,3),60,90),COLORFF0000;

庄散线

{M:60 3 120  N:30 3 120 }
STICKLINE(C>0,0,100,100,0),COLOR334400;
{STICKLINE(C>0,0,100,100,0),COLOR334400;为底色}

LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE – LC),0),3,1) / SMA(ABS((CLOSE – LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);

SGD:=CROSS(FF,MA15);
DRAWTEXT(SGD ,35 ,’上拐点’ ),COLOR0000FF;
上拐点: IF(SGD ,30 ,15),COLOR0000FF;
XGD:=CROSS(MA15,FF);
DRAWTEXT(XGD ,65 ,’下拐点’ ),COLOR00FF00;
下拐点: IF(XGD ,70 ,85),COLOR00FF00;

DRAWTEXT(CROSS(85,RSI),(HIGH * 1.02),’★’),COLORFFFFFF;
{‘★’为回调点}
VAR1:=IF(YEAR>=2038 AND MONTH>=1,0,1);
VAR2:=REF(LOW,1)*VAR1;
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100*VAR1;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3)*VAR1;
VAR5:=LLV(LOW,30)*VAR1;
VAR6:=HHV(VAR4,30)*VAR1;
VAR7:=IF(MA(CLOSE,58),1,0)*VAR1;
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*VAR1;
吸筹:IF(VAR8>100,100,VAR8)*VAR1,COLOR00FFFF;
庄家吸筹:STICKLINE(吸筹>-150,0,吸筹,6,1),COLOR00FFFF;
散户线: 100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),COLORFFFF00,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
庄家线:EMA(J,6),COLORFF00FF,LINETHICK2;

参数:
M: 3, 120, 60
N: 3, 120, 30

操盘手

Var1:=1;
Var2:=1/WINNER(CLOSE);
Var3:=MA(CLOSE,13);
Var4:=100-ABS((CLOSE-Var3)/Var3*100);
Var5:=LLV(LOW,75);
Var6:=HHV(HIGH,75);
Var7:=(Var6-Var5)/100;
Var8:=SMA((CLOSE-Var5)/Var7,20,1);
Var9:=SMA((OPEN-Var5)/Var7,20,1);
VarA:=3*Var8-2*SMA(Var8,15,1);
VarB:=3*Var9-2*SMA(Var9,15,1);
VarC:=100-VarB;
主力: (100-VarA)*Var1,color0099ff;
散户: MA(WINNER(CLOSE*0.95)*100,3)*Var1,coloryellow;
新庄: (100-IF(Var2>5,IF(Var2<100,Var2,Var4-10),0))*Var1,colorgreen,linethick1,pointdot ;
VarD:=散户>Var4;
VarE:=REF(LOW,1)*0.9;
VarF:=LOW*0.9;
Var10:=(VarF*VOL+VarE*(CAPITAL-VOL))/CAPITAL;
Var11:=EMA(Var10,30);
Var12:=CLOSE-REF(CLOSE,1);
Var13:=MAX(Var12,0);
Var14:=ABS(Var12);
Var15:=SMA(Var13,7,1)/SMA(Var14,7,1)*100;
Var16:=SMA(Var13,13,1)/SMA(Var14,13,1)*100;
Var17:=BARSCOUNT(CLOSE);
Var18:=SMA(MAX(Var12,0),6,1)/SMA(ABS(Var12),6,1)*100;
Var19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
Var1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Var1B:=SMA((SMA(Var1A,4,1)-50)*2,3,1);
Var1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Var1D:=SMA(Var1C,4,1);
Var1E:=SMA(Var1D,3,1);
Var1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
Var20:=Var18<=25 AND Var19<-95 AND Var1F>20 AND Var1B<-30 AND Var1E<30 AND Var11-CLOSE>=-0.25 AND Var15<22 AND Var16<28 AND Var17>50;
STICKLINE(VarD,Var4,散户,5,0),colorwhite;
STICKLINE(1,新庄,100,1,0),colorgreen;
STICKLINE(Var20,0,80,5,0),colorred,linethick3 ;
100,colorgreen ,linethick2 ;
0,coloryellow ,linethick2 ;
中线: 15,colorblue ,linethick2 ;

建仓减仓

var2:=REF(LOW,1);
Var3:=SMA(ABS(LOW-Var2),13,1)/SMA(MAX(LOW-Var2,0),13,1)*100;
Var4:=EMA(IF(CLOSE*1.2,Var3*13,Var3/13),13);
Var5:=LLV(LOW,34);
Var6:=HHV(Var4,34);
Var7:=IF(LLV(LOW,56),1,0);
Var8:=EMA(IF(LOW<=Var5,(Var4+Var6*2)/2,0),3)/618*Var7;
Var9:=EMA(CLOSE,5);
Var10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(10);
Var11:=EMA(IF(LOW<=Var5,(Var4+Var6*2)/2,0),3)/618*Var7*(-1);
Var12:=EMA(CLOSE,5)*(-1);
STICKLINE(Var8>REF(Var8,1),0,Var8,4,1),color10FFFF,linethick0;
主力进场:IF(Var8>REF(Var8,1),Var8*8,0),color10FFFF,linethick0;
STICKLINE(Var11>REF(Var11,1),0,Var11,4,1),colorFFF810;
洗盘:IF(Var11>REF(Var11,1),Var11*8,0),colorFFF810,linethick0;
主力持仓:LOW,colorFF10FF,linethick0;
增减力度:Var10*5,colorWHITE;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
STICKLINE(XL3,0,Var8*3,4,0),Color006EFF;
DRAWTEXT(XL3,Var8*2,’买’),Color006EFF;
↑买:DRAWICON(XL3,Var8*3,4),COLORRED;

发表评论